Building debian package for Nginx + pagespeed + passenger modules

Nginx, unlike Apache, doesn't support dynamically load additional modules. If we installed Nginx from distro's package repository, like installing for apt-get under Ubuntu, we cannot have additional nginx-somemodule package for easily installing more modules. If we need more than a standard Nginx, we have to remove the one installed with package manger, then build and install again from source. But installing via this method means we lose some advantage of package manager.

So, this tutorial will show you how to build and combine Google PageSpeed and Phusion Passenger in the same package as Nginx, to let it installed and controlled by Debian/Ubuntu's APT package manger.

Why building debian package?

  • Can revert to original Nginx by uninstall our deb package.

Việc làm cho người Việt tại Malaysia

1. Lập trình viên Python tại EasyUni

Làm việc tại Kuala Lumpur.

Nhiệm vụ

Xây dựng, bổ sung tính năng cho website: www.easyuni.com.

Hello world

Hello,

Today I start new blog system, to replace my old blogs at My Opera and Wordpress, and also to possess a website with my own domain name.

This website is started as a blog, but I have been planning to add something fun to it. The idea has existed long time ago, but because of lack of money and time, I could not start the work until now.

Well, people may say that there are many good blogging system out there, with the most noteworthy Wordpress, why not just pick one and place in some shared host, which is rather cheap and doesn't take long time. The reason why I don't do is that I want to code some features by my own. I no longer like PHP, instead I prefer Python, so I don't want to code for Wordpress. Besides, I want to write about programming (primary in Python, of course), Linux, Open source, so I want the blog system to support code highlighting, and support to write in Markdown or reStructedText, which is my new choice of writing format. Wordpress is a good platform and revolve so fast that all plugins of my need (Markdown, code highlighting) become incompatible with newest version of Wordpress.